Chevy Colorado Diesel Forum banner

1 - 20 of 69 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Hello all,
New here but been lurking for a while.
Got the DEF warning light on the dash and the countdown to limited speed of 65, then 55, now 4mph.
Independent shop with GM tech connect couldnt even detect any error codes or info at all.
Replaced both positions of NOx sensors, now since im limited to 4mph, i cant do the drive cycle to reset.
I have an obd2 scanner on the way tmrw, but im wondering is there any other way to clear the def error and force a regen without the scanner?
Ive got the battery disconnected for a half hour, was going to try to let it idle up to temp and see if it starts its own regen before trying to putt around the neighborhood to see if it does anything.
I havent gotten it in for the related recall yet, was trying to schedule before this started.
Is there anything i can do to get it cleared without the scanner?
Any tidbits appreciated
 

·
Registered
Joined
·
247 Posts
Hello all,
New here but been lurking for a while.
Got the DEF warning light on the dash and the countdown to limited speed of 65, then 55, now 4mph.
Independent shop with GM tech connect couldnt even detect any error codes or info at all.
Replaced both positions of NOx sensors, now since im limited to 4mph, i cant do the drive cycle to reset.
I have an obd2 scanner on the way tmrw, but im wondering is there any other way to clear the def error and force a regen without the scanner?
Ive got the battery disconnected for a half hour, was going to try to let it idle up to temp and see if it starts its own regen before trying to putt around the neighborhood to see if it does anything.
I havent gotten it in for the related recall yet, was trying to schedule before this started.
Is there anything i can do to get it cleared without the scanner?
Any tidbits appreciated

The DEF system has nothing to do with a regen. The DPF filter is the device that needs the regen to clear itself of trapped soot, using diesel fuel and an injector on the exhaust system just prior to the DPF filter to make that happen. It sounds like the DEF pump is not working or the DEF injector is clogged. This will cause high NOx and the impending countdown.

Let us know what you find
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
Hoping its not the pump. The force regen is only a necessary step to clear the error, i know it wont affect def injecting or function but electronically, it seems we have to go around our a hole to get to our elbow.
impatiently waiting for captain amazon to bring my stuff.
i would definitely prefer the injector to be bad or clogged rather than the pump.
 

·
Registered
Joined
·
247 Posts
LMAO... I hear ya on the whole shaabang... and roger that on the injector as opposed to the pump taking a dump.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #5 ·
Bluedriver shows pos1 and 2 both running pretty equal at 80’s to 90’s.
Still no error codes to clear.
It does show ‘incorrect reagent’, which makes me think either it is some bad def or its just parroting the dic.
Need to sit down with the user manual tmrw eve and make sure im using it and reading it all correctly but im hoping its just a drain and fill sort of situation.
 

·
Registered
Joined
·
247 Posts
Draining the tank (looking at the service manual) looks to be a PITA. I thought that if I needed to flush my tank I'm just going to drill a hole in the bottom and add a drain. It's a plastic tank so I will find a drain I can add to it for future maintenance, should have had one from the factory knowing how crusty this stuff can/will get.
 

·
Registered
Joined
·
342 Posts
Hello all,
New here but been lurking for a while.
Got the DEF warning light on the dash and the countdown to limited speed of 65, then 55, now 4mph.
Independent shop with GM tech connect couldnt even detect any error codes or info at all.
Replaced both positions of NOx sensors, now since im limited to 4mph, i cant do the drive cycle to reset.
I have an obd2 scanner on the way tmrw, but im wondering is there any other way to clear the def error and force a regen without the scanner?
Ive got the battery disconnected for a half hour, was going to try to let it idle up to temp and see if it starts its own regen before trying to putt around the neighborhood to see if it does anything.
I havent gotten it in for the related recall yet, was trying to schedule before this started.
Is there anything i can do to get it cleared without the scanner?
Any tidbits appreciated
I got the same msg.
I just added some def I purchased from the dealer. Yes I pay more there but at least they will not be able to claim bad def and my fault... so sad to bad here is your bill...

it has since went away and hasn’t come back................yet..

I noticed the def fluid started to drop real fast over a few days. Then on the way home from work the msg came up Poor DEF quality x miles till x speed....
The next day on the way to work it went away..
Since then the DEF usage has been almost non existent.
Def lasts me thousands of miles. I only ever put 1 jug in at a time because it lasts so long..
A few days later it came up with a check engine light. I check the code and it said 2nd NOX sensor out of range. I cleared the code and it has not come back........yet...

I been watching the NOX sensors and the second sits at zero most of the time.
I have read that it should show 80% less than nox sensor 1..

These are very spooky trucks.
Sure spooks me to be to far from home with it..
 

·
Registered
Joined
·
247 Posts
I got the same msg.
I just added some def I purchased from the dealer. Yes I pay more there but at least they will not be able to claim bad def and my fault... so sad to bad here is your bill...

it has since went away and hasn’t come back................yet..

I noticed the def fluid started to drop real fast over a few days. Then on the way home from work the msg came up Poor DEF quality x miles till x speed....
The next day on the way to work it went away..
Since then the DEF usage has been almost non existent.
Def lasts me thousands of miles. I only ever put 1 jug in at a time because it lasts so long..
A few days later it came up with a check engine light. I check the code and it said 2nd NOX sensor out of range. I cleared the code and it has not come back........yet...

I been watching the NOX sensors and the second sits at zero most of the time.
I have read that it should show 80% less than nox sensor 1..

These are very spooky trucks.
Sure spooks me to be to far from home with it..
Same here for the same reasons.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #9 ·
Same here for the same reasons.
Draining the tank (looking at the service manual) looks to be a PITA. I thought that if I needed to flush my tank I'm just going to drill a hole in the bottom and add a drain. It's a plastic tank so I will find a drain I can add to it for future maintenance, should have had one from the factory knowing how crusty this stuff can/will get.
yeah, draining isnt a viable option, but siphoning will have to be how i do it. Apparently thru research, it seems that you can put it into sand or absorbent of some kind and dispose of it like trash. I guess ill have to get a siphon pump and start a pumpin
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #10 ·
I got the same msg.
I just added some def I purchased from the dealer. Yes I pay more there but at least they will not be able to claim bad def and my fault... so sad to bad here is your bill...

it has since went away and hasn’t come back................yet..

I noticed the def fluid started to drop real fast over a few days. Then on the way home from work the msg came up Poor DEF quality x miles till x speed....
The next day on the way to work it went away..
Since then the DEF usage has been almost non existent.
Def lasts me thousands of miles. I only ever put 1 jug in at a time because it lasts so long..
A few days later it came up with a check engine light. I check the code and it said 2nd NOX sensor out of range. I cleared the code and it has not come back........yet...

I been watching the NOX sensors and the second sits at zero most of the time.
I have read that it should show 80% less than nox sensor 1..

These are very spooky trucks.
Sure spooks me to be to far from home with it..
This is my first spook in 138k miles, the truck isnt spooky, ive driven it from tahoe to BC four times, to wyoming, and on so many other long trips carrying a heavy camper and never an issue. Def seems like a random issue, some get it right away, some later, some not at all.
def lasts me thousand of miles too, whether pump or peak or no name brand. First issue ever with it or with the truck outside of maintenance and wearout parts. This one though, this one is a pain in the dink.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #11 ·
Update for those following.
procured a siphon pump and clean new tubing, hand pumped the def tank empty, spent a lot of time getting every drop i could. Filled with fresh def, or one 2.5 gal at least. Up to operating temp and still no changes. Had to drop the spare and undo filler neck to get the pump tubing in there.
One more session with blue driver before its time for a tow to the dealer.
Good times, we got em
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #17 ·
Just picked it up, stoked on the quick turnaround.
They said it was stuck in “level 7 limp mode”, they unstuck it from that, and did the regen recall also. Business as usual again. Thankfully only one labor hour at $175, and they made sure to mess up my tire pressures for me free of charge🤡 i run e rateds and carry a pop up camper so i run them at 41. No bigs but ironic. Level 7 limp mode sounds like it needed a viagra or something. Didnt know there were levels of limp mode. Didnt really pin down the cause, but hopefully wont give me any more trouble and my sensors are new now.
What a snafu!
 

·
Registered
Joined
·
247 Posts
It really sucks that the owner doen't have the ability to do a stationary Regen without buying an expensive OBDii scanner.
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #19 ·
So guess what. Drove 270 mi from home and the damn thing went into limp mode again. No 65mph, no 55 mph, just straight to 4mph. Same “def quality poor” msg on the dic, no cel. Gotta get towed home to the dealer and rent a car since no ride alongs with covid. Only rental car available is a convertible mustang, get to drive home like a european tourist!

This is getting ridiculous. Its been fine for a thousand miles since the last reboot of the computer and im hoping thats all it is this time, but the jump directly to limp mode has me worried.

I just drove it like 600 miles over this past weekend, palm springs to big pine CA and back, then had to come back up again to reno for a work stint. Didnt make work obviously.

This past weekends trip was up to 9500’, fully laden, carrying my camper and with my lady. Not a single issue. Hit home and found out i had to come back up to reno/tahoe for some work. Made it as far as bishop Ca and got shut down.

Local diesel shop booked out for over a week, nearest dealer 170mi further north, so i chose to use my 200 mi free tow to get it home, paying for the remaining 70mi.
 

·
Registered
Joined
·
247 Posts
Wow I hate to hear tha. If not already there, your going to have zero confidence in your truck. It would sure be nice if they got rid of the limp mode stuff. That could really leave you in a bad spot as yours did to you.
 
1 - 20 of 69 Posts
Top