Chevy Colorado Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
After Battery Was Removed For Testing Without Connecting a 12 Volt Source To OBII Connector ,Engine Developed A Rough Idle.
Has anyone done a idle relearn method without a scan tool,
 

·
Registered
Joined
·
1,018 Posts
I talked to Patrick Runge at Shield & Spear (SNS) Performance. He said that he had never heard of this happening. I asked Jason Hackler as well to see if he had heard of this but he has not replied back to me.

Patrick said that the only thing he thought of that, if nothing else was touched, perhaps there is a loose ground somewhere as to why this is happening now to you.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #3 ·
When old battery was tested it was removed, charged and tested on some GM battery testing machine that prints out a complete analysis on a piece of paper that looks like an adding machine tape. Battery was disconnected for almost 1 hour at gmc dealer. New acdelco agm battery installed. Exterior Temperature defaulted back to 32* Fuel filter defaulted back to 100 % .
I did not notice rough idle until I got home. I disconnected negative terminal for 40 minutes, Reconnected and let it idle for 10 minutes. Turned off for a minute, restarted.
Rough idle disappeared.
Week later check battery was 12.1 volts at terminals with voltmeter. Went to dealer, Battery etc was okay . They reset tire pressure relearn, told temperature would correct itself. Fuel filter was back at 100%. Had to leave to go to meeting drove, 190 miles. 2 days later checked, rough idle back. Disconnected battery etc etc This time rough idle disappeared 98 % still not excellent like before.
Most mechanics would never have this happen because they know if you do not supply voltage to computer through, OBII,,modules will lose some learned adjustments, such as fuel trim at idle and default back to factory initial values.
 
1 - 3 of 3 Posts
Top