Chevy Colorado Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
First time posting I have done a lot of research and looking for guidance!
2016 with 49k miles
6 months ago I had a MAP sensor code. I took it to the local dealership here in Eugene Oregon they told me that I had rodent eat my wiring to my MAP sensor. 400$ plus labor to install new harness and could not provide and pictures or details about where said harness was installed. Today I was throwing a MAF code took it back to same dealer. They said it’s a corroded connector in the harness and said likely caused by the repair done by previous “rodent” issue. Neither covered under warranty because they said this is a corrorsen issue. And want me to buy another 400$ harness. Arent the MAP/MAF ran into same harness? Can anyone point me into a direction to find A wiring diagram? Any help is appreciated!
 

·
Registered
Joined
·
26 Posts
Found a 2016 manual link: https://www.gmupfitter.com/files/me...Builders_Manual_Service_Manual_2016_en_US.pdf

I cleaned my MAF, but only made it a few weeks and ended up replacing the unit. Dug a little more into my air system and found the air filter had been badly damaged. I know where I had it serviced, and took the filter to them (local tire/service shop). I was not happy. Can't really prove anything, but they lost my business. Rest of the air system seemed clean, but I had another shop check my engine out thoroughly. They were very cool about it and found no issues.
 

·
Super Moderator
Joined
·
507 Posts
Sounds like some shops with no skill or no ethics.
 
1 - 3 of 3 Posts
Top