Chevy Colorado Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Anyone else experiencing random check engine lights? My truck has approx. 6500 miles on it and up until now has been fine. The other day I got some random check engine lights, and then went away a few minutes later. This morning, I received check engine lights for traction control and ABS. Lights stayed on. I'll have to check and clear the codes when i get home from work.

I'm just wondering if anyone else is experiencing this with their new trucks.

Thanks
 

·
Registered
Joined
·
1,018 Posts
On my 2004 Silverado 2500HD, the ABS light and I think either Service Brake System (not sure if that one is correct) would come on occasionally, and then go away the next time you started the vehicle. I talked to the mechanic about it and he said it was nothing to worry about, just a reminder from the truck to check your brake system and make sure it was functioning properly. Don't know if it was set off my something happening, or just a timed thing they set in the computer from the factory.

Could be that this is a similar deal.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
On my 2004 Silverado 2500HD, the ABS light and I think either Service Brake System (not sure if that one is correct) would come on occasionally, and then go away the next time you started the vehicle. I talked to the mechanic about it and he said it was nothing to worry about, just a reminder from the truck to check your brake system and make sure it was functioning properly. Don't know if it was set off my something happening, or just a timed thing they set in the computer from the factory.

Could be that this is a similar deal.
Possibly. The lights did go out when I went to leave work for home. Didn't get a chance to plug my code reader in to see if there were any stored codes. If there is, I'll probably take it in to a Chevy dealer to have them track the codes in their system and then clear them.
 

·
Registered
Joined
·
42 Posts
I just went through this with mine... At first I thought it was bad diesel. I had to stop at a "questionable" station in the middle of nowhere and started getting emissions and sensor errors almost immediately. Two good tanks later all was fine. A few months later it started happening again, but this time it was from my regular diesel. It'd throw a code for a couple days, then clear it. Rinse, repeat. Took it to the dealer where it promptly cleared itself the moment they started it to pull it into the bay. They erased the computer and it hasn't happened since. The rep told me that the computer was having some kind of communication issue with the sensors and just needed a full reset to clear it. Been fine ever since.

Also, someone else has posted that he had similar systems that may have been caused by a loose ground strap. If you're handy, it might be worth tracing a few straps before doing the dealer dance.
 

·
Registered
Joined
·
23 Posts
I had a similar problem with my truck throwing multiple codes. Turen out the wiring harness that sits under the battery and right above the shock tower had chaffed on the shock tower i tapes it up and zip tied it out of the way and havent had any problem since
 
1 - 5 of 5 Posts
Top