Chevy Colorado Diesel Forum banner

I have these messages popping up. I havnt even used my 4wd or trailer brakes? Check engine light is

  • service 4wd

    Votes: 0 0.0%
  • service trailer brake

    Votes: 1 100.0%
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have these messages popping up. I havnt even used my 4wd or trailer brakes? Check engine light is not on. I try reading code and zero codes pop up??

What is going on? I tried cleaning actuator connection. No luck? Vehicle is out of warranty. Anyone know what it might be?? Frustrating.
 

·
Registered
Joined
·
2 Posts
check the connectors around the power steering motor assembly (right between the front wheels). Mine had dirt, water and some corrosion in them as a result of "rural" usage - resulting in exactly the same errors that you report (and some more - stabilitrack errors, steering angle sensors , weird truck behavior). Also check your wiring harness for wear
 

·
Registered
Joined
·
14 Posts
I have these messages popping up. I havnt even used my 4wd or trailer brakes? Check engine light is not on. I try reading code and zero codes pop up??

What is going on? I tried cleaning actuator connection. No luck? Vehicle is out of warranty. Anyone know what it might be?? Frustrating.
Found a wire that shorted near the ac accumulator so check wire harness under the hood
 

·
Registered
Joined
·
4 Posts
Man i have had the Service 4wd come on since i have had the truck. 2017 model only used 4wd like 3 or 4 times none prior to it coming on originally. in for oil change and they say it had a code with it and changed a part within a month or two it came back on. but they want to keep my truck for a couple of days to go through it, and i just don't want to give it up for that long. it may not come on for three months and then appear like 5 times in a week then disappear for a period of time. but i have the five year warranty and will eventually get it taken care of and i made sure it was well documented with the dealership each time i went in for service. one time a technician even hooked a computer up to it but really saw nothing and just reset it, So who knows. i don't think the 4wd itself is in any danger or anything. But would like to see if other people have had the same problem or any solutions. I use the trailer brake like every day towing my lawn business trailer never had a problem with it or message. Although one time with my trailer it started just not working and eventually figured out it was the magnets in the trailer hubs itself that were screwed up. replaced those and went back to working perfectly. At the time i don't think there was a way too hook up another trailer brake controller without cutting wires and messing all that up. so luckily i found that the magnets were messed up took the trailer repair like a day to figure it out.
 

·
Registered
Joined
·
9 Posts
This happened on mine and it was the ABS sensor. Both sides were touching the hub assembly and had worn thru to the bare wires, and would short out when it touched the metal. Its an easy fix. ordering the right part is a nightmare though. there is a right and left side and it seems that the dealerships have issues figuring out the difference between the 2.
 
1 - 6 of 6 Posts
Top