Chevy Colorado Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Driving on Freeway today & noticed Stabilitrak & Traction Control lights came on. I pulled over turned off engine then started truck. No Stabilitrak & Traction Control Lights. If I toggle the switch it goes off & on. Like normal. No power loss or rough transmission feel.
What to do. I will be monitoring situation. But hoping it doesn't resume. Any thoughts experience etc. Joe
 

·
Registered
Joined
·
134 Posts
There have been a few others who had the same issue. According to them they all found wire harness chafing in different areas. Do a google search for it and maybe you can find the issue. good Luck
 

·
Registered
Joined
·
83 Posts
I had this happen to me at about 23k, now 34k. It wen off after I restarted a bit later as I was on dry road just cruising at 65 mph. It came on again about a week later so I took it to a GMC store.

They said this can happen in conjunction with an unrelated issue. In my case the stored code indicated a misfire on cylinders 2&3, so the those injectors were replaced under warranty.

I just a week ago had the same Stabilitrak light in a road trip, but when I took it to a different dealer (I am a full-time RVer and move every so often), they couldn't pull up any code.

All the above comments are from two different dealers, not me, and I never felt or experienced any engine/transmission irregularities/abnormalities.

Go figure!!
 
  • Like
Reactions: Colorado Joe

·
Registered
Joined
·
83 Posts
  • Like
Reactions: 6speedTi
1 - 5 of 5 Posts
Top