Chevy Colorado Diesel Forum banner
1 - 13 of 13 Posts

·
Registered
2017 Chevy Colorado Crew Cab Diesel
Joined
·
6 Posts
Discussion Starter · #1 ·
I am at my wits end!! I have a 2017 with 65k miles. The truck slid off an icy dirt road in VT and stopped among some brush.
(1) I then had a service DEF system warning.
The dealership scanned and found P2033 Code, went to test circuits and found wires pulled out EGT Sensor #2.
replaced sensor and I drove away with no warnings or check engine lights showing on dash
(2) Next day got "Emission System speed will be limited to 65 mph in x miles brought back to dealership and they come up with Code P20BE needs a controller Part# 39153712 ordered and then returned for it to be replaced.
(3) After installation of above still has same Emission System error message. Now being told the new code is P20BF and they need to order a pipe/RO Line:A part #84749035
part is now on order.

Anyone have an issue like this or can you advise??

Thank you
Lance
 

·
Registered
Joined
·
120 Posts
I would assume the dealer knows about the off-pavement excursion? If so then they should be looking for any signs of damage to any other parts of the wiring harness rather than hoping the computer will tell them what's wrong. If they're not physically checking for damage under the truck then I'd be asking them WTF they're getting paid to do. If you didn't tell them what caused these issues, why didn't you?

You may want to see if there's a better dealer, also talk to them about refunds for replacing parts that didn't need to be replaced because they're not doing proper troubleshooting and it sounds like they're just throwing parts at it.
 

·
Registered
2017 Chevy Colorado Crew Cab Diesel
Joined
·
6 Posts
Discussion Starter · #3 ·
I would assume the dealer knows about the off-pavement excursion? If so then they should be looking for any signs of damage to any other parts of the wiring harness rather than hoping the computer will tell them what's wrong. If they're not physically checking for damage under the truck then I'd be asking them WTF they're getting paid to do. If you didn't tell them what caused these issues, why didn't you?

You may want to see if there's a better dealer, also talk to them about refunds for replacing parts that didn't need to be replaced because they're not doing proper troubleshooting and it sounds like they're just throwing parts at it.
Thanks for the reply! Yes I told them about going off-road as the passenger side mirror got torn off and they were replacing that as well.
I just hope this last part that is on order solves the issue!
 

·
Registered
Joined
·
5 Posts
I am at my wits end!! I have a 2017 with 65k miles. The truck slid off an icy dirt road in VT and stopped among some brush.
(1) I then had a service DEF system warning.
The dealership scanned and found P2033 Code, went to test circuits and found wires pulled out EGT Sensor #2.
replaced sensor and I drove away with no warnings or check engine lights showing on dash
(2) Next day got "Emission System speed will be limited to 65 mph in x miles brought back to dealership and they come up with Code P20BE needs a controller Part# 39153712 ordered and then returned for it to be replaced.
(3) After installation of above still has same Emission System error message. Now being told the new code is P20BF and they need to order a pipe/RO Line:A part #84749035
part is now on order.

Anyone have an issue like this or can you advise??

Thank you
Lance
I feel your pain Lance, I am in the same boat....This is my third time now at mechanics for stupid emissions system failures and codes etc etc... The latest is reduced speed, now down to nothing, Mechanic found that the def line (pipe) Part # 84749035 was split open. Causing the limp mode etc...Bad news...says part is unavailable for 4 to 6 weeks...WHAT A F%$#^&* JOKE this is....Perfect running truck now parked because of stupid emission computer codes limp mode....So so so frustrating.
Once this gets fixed I am deleting everything....sounds like all fixes are only temporary until the next emission system failure starts...
If you know where to find this part let me know.
 

·
Registered
Joined
·
14 Posts
I feel your pain Lance, I am in the same boat....This is my third time now at mechanics for stupid emissions system failures and codes etc etc... The latest is reduced speed, now down to nothing, Mechanic found that the def line (pipe) Part # 84749035 was split open. Causing the limp mode etc...Bad news...says part is unavailable for 4 to 6 weeks...WHAT A F%$#^&* JOKE this is....Perfect running truck now parked because of stupid emission computer codes limp mode....So so so frustrating.
Once this gets fixed I am deleting everything....sounds like all fixes are only temporary until the next emission system failure starts...
If you know where to find this part let me know.
I had emission problems and codes and limp modes on all the time as soon as you get it fixed delete it.my 2018 has had nothing wrong since deleting make sure to also change Out exhaust needs to breath,truck gets close to 38 miles per gallon on highway running 75 .18 pulling my trailer with my tractor on it have 136 thousand on it now deleted at 82 thousand , no trouble since also pour 2 ounces of Lucas injector lub in every tank trust me this truck is notorious for injectors sticking and blowing engine no sulfur in todays fuel to lube them.make sure to change front and rear differential fluid at about 50000 and trans and differential ,truck will last only problem I have is keeping alignment probably my fought as I drive it a lot in mud .i have 17 years as a gm certified mec,before quitting and going to work for myself graduate of Nashville auto diesel collage
 

·
Registered
Joined
·
4 Posts
I had multiple emission failures about a year ago. Multiple sensors changed which did Not correct the problem. After the truck spent 3 weeks at the dealer GM Technical Support instructed the dealer to replace the wire harness which I found out after the fact that there has been a known issue. Has been a year now with no new check engine light failures. Crossing my fingers that was the issue since I like the truck.
 

·
Registered
2017 Chevy Colorado Crew Cab Diesel
Joined
·
6 Posts
Discussion Starter · #7 ·
I feel your pain Lance, I am in the same boat....This is my third time now at mechanics for stupid emissions system failures and codes etc etc... The latest is reduced speed, now down to nothing, Mechanic found that the def line (pipe) Part # 84749035 was split open. Causing the limp mode etc...Bad news...says part is unavailable for 4 to 6 weeks...WHAT A F%$#^&* JOKE this is....Perfect running truck now parked because of stupid emission computer codes limp mode....So so so frustrating.
Once this gets fixed I am deleting everything....sounds like all fixes are only temporary until the next emission system failure starts...
If you know where to find this part let me know.
Its been a week so far and no part. They said 1-3 days but apparently they are wrong. Standing by
 

·
Registered
2017 Chevy Colorado Crew Cab Diesel
Joined
·
6 Posts
Discussion Starter · #8 ·
I had emission problems and codes and limp modes on all the time as soon as you get it fixed delete it.my 2018 has had nothing wrong since deleting make sure to also change Out exhaust needs to breath,truck gets close to 38 miles per gallon on highway running 75 .18 pulling my trailer with my tractor on it have 136 thousand on it now deleted at 82 thousand , no trouble since also pour 2 ounces of Lucas injector lub in every tank trust me this truck is notorious for injectors sticking and blowing engine no sulfur in todays fuel to lube them.make sure to change front and rear differential fluid at about 50000 and trans and differential ,truck will last only problem I have is keeping alignment probably my fought as I drive it a lot in mud .i have 17 years as a gm certified mec,before quitting and going to work for myself graduate of Nashville auto diesel collage
What did you change on your exhaust system?
 

·
Registered
2017 Chevy Colorado Crew Cab Diesel
Joined
·
6 Posts
Discussion Starter · #9 ·
I had multiple emission failures about a year ago. Multiple sensors changed which did Not correct the problem. After the truck spent 3 weeks at the dealer GM Technical Support instructed the dealer to replace the wire harness which I found out after the fact that there has been a known issue. Has been a year now with no new check engine light failures. Crossing my fingers that was the issue since I like the truck.
Thank you for the heads up. At least I know now where to look if this next part doesn't solve the problem.
 

·
Registered
Joined
·
14 Posts
Just remember you can only change out exhaust components if it's deleted otherwise you will get CEL's lighting up.
Look up deletes for your truck got mine out of Canada
What did you change on your exhaust system?
I replaced the whole system with a 3” bought everything from had diesels out of Canada including tune took me about a day to remove and replace exaust after tune was installed total cost with exaust and tune 1650 well worth it check make sure your state doesn’t check for deletes when and if they do inspections ours only checks safety on diesels fuel mileage increase by 10 miles to gallon at least . Engine gained about 30 horses and breaths a lot better oil stays leaner longer I change mine when it Gets close to 20 percent left and it still looks clean now don’t listen to the so called ass wipe that’s telling you that it’s against the law and it’s hurts your engine delete as soon as warranty runs out or sell it it’s going to stay in shop with emission problems same engine in South America no emissions last 300000
 

·
Registered
2017 Chevy Colorado Crew Cab Diesel
Joined
·
6 Posts
Discussion Starter · #13 ·
I feel your pain Lance, I am in the same boat....This is my third time now at mechanics for stupid emissions system failures and codes etc etc... The latest is reduced speed, now down to nothing, Mechanic found that the def line (pipe) Part # 84749035 was split open. Causing the limp mode etc...Bad news...says part is unavailable for 4 to 6 weeks...WHAT A F%$#^&* JOKE this is....Perfect running truck now parked because of stupid emission computer codes limp mode....So so so frustrating.
Once this gets fixed I am deleting everything....sounds like all fixes are only temporary until the next emission system failure starts...
If you know where to find this part let me know.
Dealership called me today saying part is in and truck should be fixed tomorrow. Fingers crossed. Did yours ever come in?
 
1 - 13 of 13 Posts
Top